Rails3 & Globalize2

Opublikowane przez Jarosław Zabiełło Fri, 02 Jul 2010 12:42:00 GMT

Standardowa metoda umiędzynarodowienia aplikacji webowej oparta na plikach YAML, czy bibliotece Gettext, dobrze się sprawdza w przypadku tłumaczenia interfejsu aplikacji, ale już niekoniecznie w sytuacji, kiedy teksty trzymane są w bazie danych. Standardowo i18n w Rails używa plików YAML (choć można użyć Gettext lub zdefiniować zupełnie własną obsługę). Aby tłumaczyć dane trzymane w bazie, trzeba sięgnąć po odpowiedni plugin.

Jednym z najlepszych pluginów (opisywałem go w książce), jest Globalize. Niestety, Globalize nie działa z nowym Rails 3. Istnieje co prawda nowy, przebudowany od podstaw Globalize2, ale (w chwili pisania tego tekstu), nawet sam autor nie jest pewny czy działa z Rails 3. Okazuje się, że można zmusić Globalize2 do pracy z Rails 3 i to całkiem prosto.

Czytaj dalej...

Tagi , , , , , , ,  | 9 comments